Мы — долго запрягаем, быстро ездим, и сильно тормозим.

FreeBSD
Очумелые Ручки
OpenBSD
Cisco
  Дополнительные порты для роутера
  Cisco ADSL
  Cisco VPDN с RADIUS авторизацией
  IPSEC over GRE with RIP
  Двойной NAT


www.lissyara.su —> статьи —> Cisco —> Дополнительные порты для роутера

Увеличение количества маршрутизируемых портов роутера за счет коммутатора

Автор: m0ps.


ЗАДАЧА
Есть роутер CISCO (в моем варианте 2811) на котором закончились свободные Ethernet порты и есть коммутатор CATALYST  (в моем варианте 2960), который имеет уйму свободных портов. Необходимо увеличить количество Ethernet портов маршрутизатора за счет свободных портов коммутатора пробросив vlan с сабинтерфейса роутера на интерфейс коммутатора.

РЕШЕНИЕ
На роутере:
    ................................................
    !
    interface FastEthernet0/1
    description Trunk port for catalyst
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/1.122
    description SubInterface for SOMENET on vlan 122
    encapsulation dot1Q 122
    ip address 172.16.1.1 255.255.255.0
    ip virtual-reassembly
    no snmp trap link-status
    !
    .............................................

А теперь подробнее. Интерфейсу роутера Fa0/1, который физически соединен с интерфейсом коммутатора Gi1/0 указываем на отсутствие присвоенного ip адреса командой no ip address и не забываем дать команду no shutdown для "поднятия" интерфейса. Далее создаем сабинтерфейс: interface FastEthernet0/1.122, указываем тип инкапсуляции: encapsulation dot1Q 122 и конечно же присваиваем ip адрес: ip address 172.16.1.1 255.255.255.0.

Теперь на коммутаторе:
    ...................................
    !
    interface GigabitEthernet0/1
    description Smotrit na router
    switchport trunk allowed vlan 122
    switchport mode trunk
    !
    ..........................................
    !
    interface FastEthernet0/22
    description Smotrit v SOMENET
    switchport access vlan 122
    switchport mode access
    !
    ..........................................
    !
    interface Vlan122
    description SOMENET
    no ip address
    no ip route-cache
    !
    ...........................................

Для начала создаем vlan: vlan 122 и называем его, как вздумается: name SOME. Далее конфигурируем тот порт, который смотрит на роутер interface GigabitEthernet0/1. Он будет транковым портом, для этого выполняем команду switchport mode trunk. В случае если коммутатор поддерживает несколько видов инкапсуляции транка даем команду switchport trunk encapsulation dot1q для того что бы коммутатор знал что нужно использовать инкапсуляцию dot1Q, далее указываем какие vlan'ы могут ходить через этот транк: switchport trunk allowed vlan 122. Теперь переходим к конфигурации порта, который и будет физически дополнительным портом для маршрутизатора. interface FastEthernet0/22, включаем vlan на порту switchport mode access а теперь указываем какому vlan'y принадлежит этот порт: switchport access vlan 122.

Все! Теперь пробуем пинговать с роутера клиента, подключённого к порту Fa22 на коммутаторе, результат должен быть положительный.

ВНИМАНИЕ:
Для того что бы коммутатор сам не переводил интерфейс в даун (статус порта выглядит как line protocol is down (err-disabled)) необходимо отключить STP на используемых для проброса интерфейса vlan'ах. Сделать это можно следующей командой: no spanning-tree vlan 122


Если нужно добавить еще один виртуальный порт, тогда добавляем следующее в конфиги:
Роутер
    ................................................
    interface FastEthernet0/1.121
    description SubInterface for TEST on vlan 121
    encapsulation dot1Q 121
    ip address 192.168.1.1 255.255.255.0
    ip virtual-reassembly
    no snmp trap link-status
    !
    .............................................

Коммутатор
    ...................................
    !
    interface GigabitEthernet0/1
    switchport trunk allowed vlan 121,122
    !
    ..........................................
    !
    interface FastEthernet0/21
    description Smotrit v TEST
    switchport access vlan 121
    switchport mode access
    !
    ..........................................
    !
    interface Vlan121
    description TEST
    no ip address
    no ip route-cache
    !
    ...........................................

Все делается по аналогии, единственное что, дак это нужно не забыть на транковом порту коммутатора разрешить новому vlan'y ходить в сторону маршрутизатора. Для этого на интерфейсе GigabitEthernet0/1 выполняем команду switchport trunk allowed vlan 121,122

P.S. Огромное спасибо lissyara за этот замечательный сайт, а также zingel за помощь на форуме в решении проблем.



Ссылка на обсуждение: http://forum.lissyara.su/viewtopic.php?f=48&t=11386.

размещено: 2008-10-09,
последнее обновление: 2008-10-09,
автор: m0ps

оценить статью:

nikll, 2008-10-09 в 12:27:24

Урра! Началось, кискари обьеденились с фришниками :)))
Ну а полобольшему счету статья оч полезная, лично я бы сроду не додумался вот ТАК изголится.

Побольше хороших статьей под любые системы, и всем будет прощще работать.

www2, 2008-10-09 в 14:03:39

Америка вновь открыта!

Слава Колумбу!

Nokitel , 2008-10-09 в 15:11:01

Молодец хороший результат, эффективная статья. Взял в колекцию.

arksu, 2008-10-10 в 8:44:25

nikll
Ну а полобольшему счету статья оч полезная, лично я бы сроду не додумался вот ТАК изголится.

я тебе про тоже самое говорил - только хотел так же сделать на роутере фришном использовав порты управляемого свитча =)

MarunYA, 2008-10-12 в 2:45:34

Отличная статья! Оригинальное и вполне реальное решение! Взял в коллекцию!

atckoe, 2008-10-24 в 14:01:49

1. не совсем понятно зачем создавать интерфейс vlan? автор что то не допонимает? достаточно создать вилан в базе виланов это делается одной командой, но в зависимости от свитча разной:) (имеется ввиду различные линейки свитчей cisco)
либо conf t > vlan №
либо conf t > vlan database > vlan №
далее смотрим есть ли новый vlan в базе vlan-ов
sh vlan
2. не совсем ясен смысл опции switchport mode access на порту свитча на котором уже прописан switchport access vlan 121, ы?
вы думаете что свитч как буратино? то есть тупой как дрова и не поймет в каком mode работать порту? :D

www2, 2008-10-24 в 15:36:46

>не совсем ясен смысл опции switchport mode access на порту свитча на котором уже прописан switchport access vlan 121, ы?

Сами подумайте. Порт может работать в режиме транка - тогда он ожидает наличие метки в пакете. Может работать в режиме пользователя, тогда он ожидает пакеты без меток, а подразумеваться будет указанная конкретная метка. Может работать в смешанном режиме - обрабатывать пакеты с метками, а пакеты без метки будет причислять к указанному vlan (обычно это 1).

atckoe, 2008-10-24 в 18:00:10

>Сами подумайте. Порт может работать в режиме транка - тогда он ожидает наличие метки в пакете. Может работать в режиме пользователя, тогда он ожидает пакеты без меток, а подразумеваться будет указанная конкретная метка.

Применимо к случаю описанному в этой статье вполне хватит switchport access vlan 121.

andrey262, 2008-11-26 в 17:47:48

Странная статья... Такое ощущения, что автор Cisco первый раз в руки взял ;-) Но ведь когдат-то надо учитсья.

m0ps, 2008-11-26 в 17:49:44

так и есть

andrey262, 2008-11-26 в 17:57:15

2:m0ps
Ну на самом деле описаное - это не оригинальное решение, а вполне описанное самой циской в базовых учебниках о началах построения сетей. Хотелось бы пожелать учить вначале матчасть, а уж потом изобретать велосипед. Кстати с cisco нетревиальных веще вообще не бывает (за редким очень! исключением). Но ведь CCIE не все идут сдавать. Удачи ;-)

Inri, 2008-12-18 в 23:34:02

Решение, описанное в этой статье, называется "router-on-a-stick"(роутер на палочке).
Ещё можно докупить свитчед-лайнкарту к 28ой. В любом случае, помните, что порты роутера никак не access-порты, не та стоимость пер порт, и обычно делается именно router-on-a-stick.

int vl121 не нужен, no spanning не нужен.

m0ps, 2008-12-18 в 23:45:54

Inri, насчет int vl121 эт действительно не нужно а насчет no spanning не согласен... по-крайней мере в моем случае эт нужно, т.к. до выключения его у меня каталист произвольно тушил интерфейс

andrey262, 2009-02-09 в 9:45:20

Не произвольно, а согласно обсчитаному дереву, если что-то тушит, значит где-то кольцо, либо его вероятность!

camelot, 2009-02-15 в 15:47:13

Если в аксесный порт подключено нечто, что может слать bpdu, то каталист может положить порт в ерр-дизейбл. Если есть уверенность что кольца не будет, можно сказать на порту spanning-tree bpdufilter enable. А моде на некоторых свичах укзывать надо, ибо они там по умолчанию стоят как dynamic, также свич разрешает иметь одновременно на порту switchport trunk allowed vlan хххх и switchport access vlan xxxx.
А еще если хотите юзать вланы выше 1000-ного, то надо перевести vtp в режим transparent (vtp mode transparent)

andrey262, 2009-04-15 в 9:42:44

Если на порту стоит portfast. Иначе не будет.

sasuke, 2009-04-21 в 22:34:36

как известно encapsulation dot1Q это универсальная инкапсуляция для Вланов, свич кошки можно сменить на другой а как сделать что непосредственно цисовским протоколом они менялись значениями вланов?

andrey262, 2010-04-29 в 20:30:50

2sasuke:
Смотри в сторону vtp-domains ;-)

roman_ssh, 2010-07-16 в 16:36:51

Статья абсолютно не соответствует своему названию, полагаю для начала нужно определиться для чего нужно "Увеличение количества портов роутера", лично я вижу только один вариант, пропускная способность, в данном случае её кпд<0. Думаю название должно быть что-то вроде "Создание vlan в роутерах и коммутаторах", хотя, для начинающих весьма полезно и доходчиво.

dmitryg, 2010-09-30 в 8:02:56

m0ps, 2008-12-18 в 23:45:54

Inri, насчет int vl121 эт действительно не нужно а насчет no spanning не согласен... по-крайней мере в моем случае эт нужно, т.к. до выключения его у меня каталист произвольно тушил интерфейс


Для того чтоб свитч не тушил интерфейс, выставь по умолчанию дуплекс и скорость на портах с двух сторон.
speed 100
duplex full

Nadz Goldman, 2010-11-12 в 12:49:40

Поправка для неучей:
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
spanning-tree guard root
избавит от херни

Patrick, 2015-01-30 в 17:34:30

Вот посмотрел на етот конфиг, можно не избретать велосипед, - не проще сделать vtp domain сделать спаниг три между 2-я портами роутера и 2-я портами свича, и на свиче раздавать акцеси для вланов, если кому интересно, - могу скинуть рабочий конфиг (щас просто нет доступа до девайсов)

Nadz Goldman, 2015-01-30 в 19:44:13

> Patrick
Статья лохматого года и ориентированна на новичков, которые не совсем понимают уровень ICND.

Смысл статьи можно вот так передать:
sw-1

int fa0/1
descr ToRouter
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 30,40
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
spanning-tree guard root
no cdp enable

int fa0/2
descr ToClient1-vlan30
switchport
switchport mode access
switchport access vlan 30
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
spanning-tree guard root
no cdp enable

int fa0/3
descr ToClient2-vlan40
switchport
switchport mode access
switchport access vlan 40
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
spanning-tree guard root
no cdp enable

---
rt-1

interface FastEthernet0/0
descr To-sw-1
no ip address
duplex auto
speed auto
no shutdown

interface FastEthernet0/0.30
descr subInt-vlan30
encapsulation dot1Q 30
ip address 10.10.30.0 255.255.255.0

interface FastEthernet0/0.40
descr subInt-vlan40
encapsulation dot1Q 40
ip address 10.10.40.0 255.255.255.0


Т.е. суть этой статьи была в том, что бы новички, которые дома имели какой-нить длинк/зухель и прочее могли хоть чуть-чуть въехать в основы транков/акцессов при работе с более "умными" устройствами.

Мне, к примеру, нынче это всё пофиг - вышеприведенный конфиг накидал с руки.
Но когда-то именно таких штук и не хватало.

А vtp domain давным давно умер =)
Остался жив ещё stp, но и с него надо перелазить на что-то другое.


Оставьте свой комментарий:
Ваше имя:   *
e-mail:  
жирный
наклонный
подчёркнутый
ссылка
цвет
Нынешний год:   *
 


Хостинг HOST-FOOD

2014-07-27, lissyara
gmirror

Удалённое создание софтверного зеркала средствами gmirror, на диске разбитом с использованием gpart. Использование меток дисков для монтирования разделов.
2013-08-20, zentarim
Scan+Print server FreeBSD 9

Настройка сервера печати и сервера сканирования под управлением операционной системы FreebSD 9 для МФУ Canon PIXMA MP540
2011-11-20, BlackCat
Разъём на WiFi-карту

Делаем съёмной несъёмную антену на WiFi-карте путём установки ВЧ-разъёма
2011-09-14, manefesto
Настройка git+gitosis

Настройка системы контроля версия исходного кода в связке git+gitosis+ssh
2011-08-14, zentarim
Wi-FI роутер + DHCP + DNS

Настройка Wi-Fi роутера на Freebsd 8 + DNS сервер + DHCP сервер: чтобы Wi-Fi клиенты были в одной подсети с проводными, проводные и беспроводные клиенты получали адреса автоматически по DHCP, кэширующ
2011-06-15, -ZG-
Охранная система на FreeBSD+LPT

В этой статье описана попытка реализации простой охранной системы на базе FreeBSD с подключением к ней охранных устройтсв на LPT порт и видеорегистрацией.
2011-03-13, terminus
ng_nat

Описание работы ng_nat, практическое использование, достоинства и недостатки в сравнении с ipfw nat
2011-02-20, Капитан
Nagios+Digitemp

Статья описывает создание системы оповещения о превышении температуры в специальных помещениях на основе Nagios с использованием программы Digitemp.
2011-02-17, Le1
Zyxel Configuration

Скрипт для массового изменения конфига свичей Zyxel. Берет из файла iplist список ip-шек, заходит последовательно на каждый и выполняет комманды из файла commands, записывая происходящее в лог файл.
2011-02-16, fox
hast carp zfs ucarp cluster

HAST (Highly Available Storage), CARP, UCARP, ZFS, Cluster настройка и одаптация плюс личные размышления…
2011-02-04, BlackCat
Восстановление ZFS

История о том, как был восстановлен развалившийся RAIDZ ZFS-пул (перешедший в FAULTED) с помощью скотча и подручных средств. Или о том, какие приключения ожидают тех, кто не делает резервных копий.
2011-02-03, Капитан
1-Wire

Статья описывает самостоятельное изготовление контроллера DS9097 для съёма показаний с датчиков температуры DS1820 с помощью программы Digitemp.
2011-01-28, Капитан
Температура в серверной

Статья описывает построение системы наблюдения за температурой в помещении серверной с использованием программы Digitemp и выводом графиков в MRTG
2011-01-21, m4rkell
Syslog server

Как то буквально на днях, у нас завалилось, что то в еве) или не в еве не суть. Суть в том, что когда захотели снять логи с хостов esx обнаружили, что хранят эти негодяи логии только за последнии сутк
подписка

    вверх      
Статистика сайта
Сейчас на сайте находится: 16 чел.
За последние 30 мин было: 63 человек
За сегодня было
2596 показов,
357 уникальных IP
 

  Этот информационный блок появился по той простой причине, что многие считают нормальным, брать чужую информацию не уведомляя автора (что не так страшно), и не оставляя линк на оригинал и автора — что более существенно. Я не против распространения информации — только за. Только условие простое — извольте подписывать автора, и оставлять линк на оригинальную страницу в виде прямой, активной, нескриптовой, незакрытой от индексирования, и не запрещенной для следования роботов ссылки.
  Если соизволите поставить автора в известность — то вообще почёт вам и уважение.

© lissyara 2006-10-24 08:47 MSK

Приобрести коммутатор CISCO в интернет-магазине с доставкой!

Время генерации страницы 0.1184 секунд
Из них PHP: 55%; SQL: 45%; Число SQL-запросов: 45 шт.
Исходный размер: 66406; Сжатая: 15519